Exception when running AvalonDock Solution

May 24, 2010 at 7:08 PM
Edited May 24, 2010 at 7:10 PM

Hi,

i just downloaded the lastes code release. When I run the test project and try to open any new item, I get an InvalidOperationException in DockingManger.cs Line 2272 with the Message: Element already has a logical parent. It must be detached from the old parent before it is attached to a new one.

What can I do to get the TestProject running?

This relates to Version 1.3

regards

Joachim

May 26, 2010 at 7:22 AM
Just tested with build 1.3.3341 and seems to work fine.
Could you please specify version of AvalonDock and steps to reproduce the problem?
thanks,
Ado
From: [email removed]
Sent: Monday, May 24, 2010 9:08 PM
To: [email removed]
Subject: Exception when running AvalonDock Solution [AvalonDock:213676]

From: joachimb

Hi,

i just downloaded the lastes code release. When I run the test project and try to open any new item, I get an InvalidOperationException in DockingManger.cs Line 2272 with the Message: Element already has a logical parent. It must be detached from the old parent before it is attached to a new one.

What can I do to get the TestProject running?

regards

Joachim

May 27, 2010 at 6:42 PM

Actually, it seems to work now with the latest release. Thank you!

One Question however: When in the demo app I save a layout and then restore it again, it will always load the initial layout, not the one I saved before. What do I have to do to load a custom layout?

regards

Joachim