[Version 2.0] Weird docking problem

Jun 6, 2012 at 10:06 AM
Edited Jun 6, 2012 at 1:19 PM

Hello

 

I've encountered a weird docking problem on a workstation with dual screen :

http://img513.imageshack.us/img513/89/pbavalondock.jpg

Panel can't be redocked, mouse position calculation seems to be wrong (mouse pointer is on the active Document 1)

Can't reproduce the problem on my workstation, even if I switch to dual screen :/

Both are on Vista ...

Any clue ?

 

EDIT : tried to remove dual screen on the "bugged" workstation, and the problem is the same ...

Jun 6, 2012 at 9:39 PM

It appears to be an issue with the dual monitor, I knew that debuggig it would have been a pain (even because I don't have a 2 monitor :). Do you have a different resolution on the secondarty monitor? do yuo have any custom DPI setting on the bugged workstation?

Jun 13, 2012 at 11:14 AM

No special DPI ... it's a standard resolution.

As I said, dual screen isn't the problem, as I tested on an other workstation with dualscreen, and it works :)

Jun 20, 2012 at 2:33 AM
Edited Jun 20, 2012 at 2:37 AM

Hi,

Firstly, I think AvalonDock is a fantastic MDI!

I too have the same issue.

I have put a video of the problem here:

http://db.tt/rhsAQmnj

As you can see, I can interact with the interface when it comes to buttons and basic dragging, but when it comes to docking floating windows, the mouse position doesn't seem to line up with were the interface thinks it is.  As you can see in the video, it becomes much worse when the window is moved.

AvalonDock is the only interface that exhibits this problem.  For example, Visual Studio 2010 works without an issue.

I have done the following testing:

  • Stopped all programs on my machine that interact with mouse positioning - the issue was still there
  • Updated my video, mouse, touchpad drivers - the issue was still there
  • Interacted with it via my mouse and touchpad - the issue was still there
  • Ran it on an external monitor and on my laptop monitor only - the issue was still there
  • Rebooted and ran it when in "safe mode" - it worked without issue
  • Ran the program on a different laptop with identical hardware and video drivers  (I am in an office with lots of computers available) - it worked without issue.
  • Ran the program on a whole host of different hardware - it worked without issue.
  • Ran the program in a VMware virtual machine on my computer - it worked without issue.

I am running Windows 7 Enterprise SP1 on a Dell 6520 laptop.

Any help would be greatly appreciated!

Thanks,

Ryan

Jul 17, 2012 at 3:10 PM

@ado : is there a way to help debugging this ?

Aug 3, 2012 at 1:24 PM

Problem has disapeared... how ? do not know.

Maybe fixed, or not.