This project is read-only.

[Version 2.0] why AvalonDock latest version pointing to in Xamal

Jul 2, 2012 at 3:40 AM


I want to use latest build , but when i started to look, i saw its pointing to in Xamal, if i remove this , then i don't see most of properties?


curious why its pointing, and if i start to use may be later , i can not use functionality ,because its pointing to codeplex and if some thing change there .


any one know?

Jul 2, 2012 at 4:51 PM
Edited Jul 2, 2012 at 9:45 PM

I ended up adding source to my solution, then using the following references:


Jul 3, 2012 at 8:09 PM

declaring  xmlns:avalonDock=""

is the same than  used by microsoft for example in  xmlns=""

declaring this xml namespace definition is the same than declaring all the avalonDock namespaces, try to see AssemblyInfo.cs of the AvalonDock library.

it's a more clean way to define all the namespaces of AvalonDock, but you can use the classic definition declaring the namespace and assembly.

Jul 3, 2012 at 8:24 PM

Yeah, but what if your build machine doesn't have internet?

Jul 3, 2012 at 8:37 PM

It's not a site address... your build machine doesn't go to search it on internet !!!!

It's a naming convention like microsoft use for their schemas !!! You can use a causal string even "pippo"

To see how it works you must see the AssemblyInfo in which is declared:

[assembly: XmlnsPrefix("", "avalondock")]
[assembly: XmlnsDefinition("", "AvalonDock")]
[assembly: XmlnsDefinition("", "AvalonDock.Controls")]
[assembly: XmlnsDefinition("", "AvalonDock.Converters")]
[assembly: XmlnsDefinition("", "AvalonDock.Layout")]
[assembly: XmlnsDefinition("", "AvalonDock.Themes")]

if you substitute "pippo" to "" and rebuild AvalonDock you can use "pippo" in your xaml as namespace definition.

You have to see this declaration as an alias of all the namespaces.

But in the end if you are not convinced try google about 

Jul 3, 2012 at 8:45 PM

Right on, thanks for the clarification. My build machine was failing then for some other reason when I tried to use the Xml namespace (as opposed to referencing like I did above). Weird.

Jul 3, 2012 at 10:33 PM

working for me.


Thanks march22.


Jrbrass, you may be change http://avalonDock.Codeplex, and then close all xaml,

and then recompile ll work.


Aug 14, 2012 at 12:40 PM

I had this issue also. I solved it by changing the 'downloaded from internet' flag that windows puts on files. Right-Click on the dll in explorer go to properties and there should be an 'unlock' button it only appears if it's locked otherwise there is no indication.